Author Topic: Session Verification Failed?  (Read 14186 times)

0 Members and 1 Guest are viewing this topic.

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Session Verification Failed?
« on: June 24, 2010, 09:12:46 PM »
Anyone else been getting this recently? Occasionally, on the first time I attempt to edit one of my posts, it has started giving me this error and telling me to try logging in again. Simply going back and trying again works, though, so it's not too much of a hassle.
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Re: Session Verification Failed?
« Reply #1 on: September 15, 2010, 07:15:05 AM »
Now this is strange. Another error just popped up related to this. It's weird, because I'm having the same errors on another forum running the same software.


"Your session timed out while posting. Please try to re-submit your message."

This happens sometimes when I hit Preview and then try to post afterwards. Is this a cookie setting issue?
« Last Edit: September 15, 2010, 07:15:55 AM by Peardian »
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!

Offline bustin98

  • Administrator
  • *****
  • Posts: 331
Re: Session Verification Failed?
« Reply #2 on: September 15, 2010, 11:58:04 AM »
I ran into this when I had the Google Chrome frame installed in IE8. I don't know the cause of it, and until it happens to more than one user I can't say thats its an issue with the software and not something on your end.

Show me how to re-create it and that will go a long way.

Offline TerraEsperZ

  • Hero Member
  • *****
  • Posts: 2258
Re: Session Verification Failed?
« Reply #3 on: September 15, 2010, 01:42:40 PM »
That's funny, that used to happen to me when trying to post from work. I use Firefox Portable since my office computer only has IE8. I didn't mention it before because I figured it must have been some sort of network security glitch.
Current project that I really should try to finish:
-Equinox (SNES)
-Drill Dozer (GBA)
-Sonic 3D Blast (Genesis)
-Naya's Quest (PC)

Pending project:
-A ton of stuff that will never be finished

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Re: Session Verification Failed?
« Reply #4 on: September 15, 2010, 03:20:56 PM »
That's the thing, it's seemingly random. I'll click edit, and it will reject me. Or, I'll preview a post, submit it, and get redirected back to the post page. Attempting the action immediately afterward always works.
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Re: Session Verification Failed?
« Reply #5 on: September 22, 2010, 03:15:36 PM »
So today in my PHP class we learned about Sessions and SIDs. And then today on another messageboard that uses the same software, we figured out that their verification problem was being caused by the SID being passed through the URL. Unless I'm mistaken and sesc is not what I think it is, there might be a similar issue causing the problems here. :P
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!

Offline bustin98

  • Administrator
  • *****
  • Posts: 331
Re: Session Verification Failed?
« Reply #6 on: September 22, 2010, 07:10:56 PM »
sesc?

I haven't seen that.

I did a google and found a discussion on SMF's forums, but its with RC2 (we're on 1) and the error crops up when accessing the same scripts across subdomains, which isn't done here either.

All I can suggest, clear your cache, delete your cookies, shut down your computer. Bring it back up and login to the site. See if you can edit one of your posts.

This is an edit of my post...

Another edit: nope, no issues.
« Last Edit: September 22, 2010, 07:12:11 PM by bustin98 »

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Re: Session Verification Failed?
« Reply #7 on: September 22, 2010, 07:44:30 PM »
I'm not sure if that will do anything. It's affecting multiple browsers, even ones that never visited this site before. If it is indeed the same problem the other message board was having, it's a problem with how the board software is handling sessions. I hit refresh there and was given a new Session ID, so that's a possible cause. I'll try and pay closer attention to the circumstances that lead up to the error.

Edit: I managed to duplicate it right now. This is indeed the case. While the sesc was being passed through the URL, I hit refresh, and it gave me a new one, which screwed with things. In fact, I was able to cause it to screw up twice in a row (a first) by subsequently trying to edit this post after hitting back.
« Last Edit: September 22, 2010, 07:46:31 PM by Peardian »
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!

Offline bustin98

  • Administrator
  • *****
  • Posts: 331
Re: Session Verification Failed?
« Reply #8 on: September 22, 2010, 07:46:04 PM »
Do you have access to another computer? Like at school, can you get it to happen there?

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Re: Session Verification Failed?
« Reply #9 on: September 22, 2010, 07:50:35 PM »
I have access to a computer lab Friday afternoon. I'll try and remember to test it there, but I'm guessing I'll get the same results.


Also, I'm curious, but why do all the forum/post numbers end in .0?
« Last Edit: September 22, 2010, 07:54:55 PM by Peardian »
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!

Offline bustin98

  • Administrator
  • *****
  • Posts: 331
Re: Session Verification Failed?
« Reply #10 on: September 23, 2010, 05:38:05 AM »
?? Just how the forum works. I didn't set something to have it that way.

Offline Peardian

  • Hero Member
  • *****
  • Posts: 627
  • Busy busy
Re: Session Verification Failed?
« Reply #11 on: September 23, 2010, 09:11:35 AM »
Ohhhh I see why now. It's used for jumping to posts/page numbers.



Edit: Something about the school's internet prevents me from logging in to... pretty much anything that isn't the school, even on my laptop. I don't expect any different from the lab tomorrow.


Edit: Oops, forgot to check in the lab. Was too busy analyzing pollypocket.com (don't ask). :-[
« Last Edit: September 24, 2010, 07:59:48 PM by Peardian »
MM (10%) - SMA3 (33%) - DNS (0%)

Come check out the Nintendo 64 Mapping Workshop!